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SECTION I: Working with Macros and Customization
LESSON ITEM #1:  Record a Basic Macro
Record a Basic Macro
Action:
1. Open Macro Practice.
2. Make sure the Inventory Listing 1 worksheet is active.
3. Select cell F1.
4. Go to the View tab and choose the Macros drop down. 
5. Select Record a Macro.
6. The Record Macro dialog box appears. 
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7. Name the Macro: ArialBlack12
a. A shortcut key is optional. It is not necessary to complete a macro.
8. The Macro is now recording. 
9. Go to the Home tab.
10. Select the Bold key, Arial Black font, and size 12 font. 
11. Return to the View tab, and select the Macro dropdown. 
12. Select Stop Recording. 
13. Select A4:D192.
14. Under the Macros dropdown, select View Macros.
15. Select the ArialBlack12 Macro and select Run.
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SECTION II: Adding Pictures and Shapes to a Worksheet
LESSON ITEM #2:  Inserting Pictures
Insert a Picture from a File
Action:
1. Open a Blank Document if you don’t already have one opened.
2. On the Insert tab, in the Illustrations group, click the Pictures button. 
3. Navigate to the Lesson folder and double-click on the dogs_life picture.
4. Notice the Picture Tools Toolbar appears. 
5. Navigate through the Picture Tools Toolbar and try out all of the changes you can make.

LESSON ITEM #3:  Adding Shapes, Lines, Text Boxes, and WordArt
Add a Shape
Action:
1. Open Shapes Practice.
2. Ensure the Ad Buy Constraints tab is active.
3. On the Insert tab, in the Illustrations group, click the Shapes button. 
4. In the Block Arrows section, click the Left Arrow shape. 
5. Move the mouse pointer onto the worksheet, just beside the Minimum Audience row.
a. Draw the shape by clicking and dragging down and a little to the right. The shape appears as you drag.
6. When the shape is the desired size, release the mouse button.
7. Notice the Shape Tools Toolbar and the commands found within. 
8. Go to the Shape Outline command and choose Red Accent, 2 in the Shape Styles group.

Draw Lines
Action:
1. On the Insert tab, in the Illustrations group, click the Shapes button.
2. In the Lines section, click the Arrow line.
3. Move the mouse pointer onto the worksheet, and click over the left side of cell I15 and drag diagonally up and to the left, toward cell G11.
4. When the line is complete, release the mouse button.
5. Notice the Shape Tools Toolbar and the commands found within.
6. In the Shape Styles, click the more arrow and Intense Line – Dark 1.

Adding Text to a Shape
Action:
1. On the Insert tab, in the Illustrations group, click the Shapes button.
2. In the Stars and Banners section, click the Explosion 1 shape.
3. Click and drag the mouse pointer next to the end of the arrow just created.
4. With the shape still selected, type Audience So Far!
5. Bold and center the text, and change the font to 14 pt.
6. On the Shape Tools Toolbar, in the Shape Styles group, choose Shape Outline – Red, Accent 2.
7. Additional Formatting can be done on the Shape Tools Toolbar.
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SECTION III: Creating Charts
LESSON ITEM #4:  Building Charts
Select Data to Include in a Chart
Action:
1. Open Pie Chart Practice.
2. Select A5:B8, click the Insert tab, and click Pie in the Charts group. Click the first 2-D Pie Chart. 
3. Move the mouse pointer to a blank spot within the chart and drag the chart to move it below the data. 
4. Click outside of the chart, click the File tab, and then click Print. 
a. Notice the Air Quality Index Report data appears in the Print Preview.
5. Press the Esc key on the keyboard and click on the Chart.
6. Go to the File tab, and choose Print. 
a. Now the chart is by itself on the Print Preview.
7. Press the Esc key.

Use Recommended Charts
Action:
1. Open the Charts Practice.
2. Select A3:B22.
3. Click the Insert tab, and then click Recommended Charts button. 
4. Click through both chart recommendations and read the description.
5. Click the Clustered Bar chart, and then click OK.

LESSON ITEM #5:  Formatting a Chart with a Quick Style 
Format a Chart with a Quick Style
Action: 
1. Click on the chart to activate the Design tab on the Chart Tools Toolbar.
2. Notice one of the Chart Styles is already selected. Click through each style until you come to the style that you prefer.
3. The chart colors are determined by the theme of your worksheet.
4. Click the Change Colors button and move the mouse pointer over each of the different rows to see a preview of the pie change.
5. Choose a Color row to make the change.

LESSON ITEM #6:  Formatting Parts of a Chart Manually
Edit and Add Text on Charts
Action:
1. Open Chart 2 Practice.
2. Click the Bar Chart.
3. Click the chart title, select the Chart Title and hit the delete key. 
4. Type: Annual Sales. 


LESSON ITEM #7:  Modifying a Chart
Add Elements to a Chart
Action:
1. Click on the Design tab and click the Add Chart Elements button
2. Choose the Axis Titles option and add both a vertical and horizontal axis.
3. Select the vertical Axis Title and type: Thousands. 
4. Select the horizontal Axis Title and type: Annual

Choose a Different Chart Type
Action:
1. Click the Design tab and select the Change Chart Type button. 
2. Click each of the chart types to see the different options. 
3. Click the Column button and choose Stacked Column.
4. Click OK.
5. On the Design tab, using the Change Chart Type button, change the chart back to a Clustered Column.

Switch between Rows and Columns in Source Data
Action:
1. On the Design tab, click the Switch Row/Column button. 
a. This will allow you to switch which information is found in the chart.
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LESSON ITEM #8:  Creating Pivot Tables and Pivot Charts
Create a Basic Pivot Table
Action:
1. Open the Pivot Tables Practice.
2. Click cell A1. Press Ctrl + End
a. Notice that there are 139,129 rows of data.
3. Press Ctrl + Home to return to the top of the worksheet.
4. On the Insert tab, click the Recommended PivotTables button.
5. Scroll to the bottom and click Count of ScaleScore by Proficiency Level.
6. Click OK and name the new sheet Count. The PivotTable Fields pane opens on the right side of your screen and the data appears on the worksheet.
a. Notice that the data for No Score is blank. That is because the count of the rows is based on the Scale Score, which is empty for unavailable scores. You will want to change the field to count to a field that has data. If you look back on the Data tab, every row is filled by a grade so you can use this column so every row is counted.
7. Return to the Counts sheet and drag the Grade field in the PivotTable Fields pane down to the Values section.
8. Drag the Count of ScaleScore from the Values section into the worksheet to remove it. Notice that the No Score row now counts each missing score.
9. Drag the Grade field to the Columns area. You’ll see each grade summarized.
a. You should have a Grade field in both the Values and Columns fields.
10. Drag the Test field to the Filters area.
11. Cell B1 currently shows (All). Click the Filter drop-down arrow, choose Math, and click OK.
12. On the Filter button, click cell B1 and choose Reading. Click OK.
Note: This Pivot table is showing you the proficiency found in each grade level.
Add a Pivot Chart
Action:
1. On the Data worksheet, click cell A1.
2. On the Insert tab, click the PivotChart button, and then choose PivotChart. 
3. The default location is for a New Worksheet, click OK. 
4. Name the new sheet tab PivotChart.
5. Drag the Test field to the Filters area.
6. Drag Grade to the Values area.
7. Drag Grade again to the Axis area.
8. Drag Proficiency Level to the Legend area.
9. Move the chart to the left edge of the worksheet, below the data, and then resize the chart so that it is the same width as the data.
10. On the Test drop-down arrow on the chart, choose Science and click OK. 
a. Notice that only 5th, 8th, and 10th grades are available because only those grades take the Science test.
11. Notice the PivotChart Toolbar and the tabs that correspond to see all of the changes that can be made to the PivotChart.
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SECTION IV: Using Advanced Formulas
LESSON ITEM #9:  Use Formulas to Conditionally Summarize Data
Using SUMIF
Action:
1. Open Functions Practice and ensure the Functions Practice tab is active. 
2. Select C20. Click the Formulas button found to the left of the formulas bar.  
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3. The Insert Function dialog box appears.
4. In the Search for Function box, type: SUMIF. Click Go.
5. Select SUMIF and click OK.
6. In the Function Arguments dialog box, put the insertion point in the Range argument.
7. Select the cell range C5:C16.
8. In the Criteria box, type >200000.
9. The Sum_range text box is not bold. This means that this argument is optional. 
a. If you leave the Sum_range blank, Excel sums the cells you enter in the Range box. You now applied your criteria to sum all values that are greater than $200,000.
10. Click OK to accept the changes and close the dialog box. 
a. You see that $1,657,100 of November revenue came from properties valued in excess of $200,000.
11. Select cell C21, and in the Formulas Tab, in the Function Library group, click Recently Used, and then choose SUMIF. 
12. In the Range field, select cells E5:E16. Press Tab.
13. In the Criteria box, type <3% and press Tab. 
14. In the Sum_range field, select C5:C16. 
a. The formula in C21 is different than the formula in C20. In C21, the criteria range is different than the sum range. In C20, the criteria range and the sum range are the same. 
15. Click OK.

Using COUNTIF
Counts the number of cells in a given range that meet a specific condition.
Action:
1. Select C24. 
2. Click the Insert Function symbol and search for and select COUNTIF.
3. In the Function Arguments dialog box, in the Range box, select cells B5:B16.
4. In the Criteria box, type >=200000 and press Tab. 
5. Preview the result and click OK. 
a. You set your criteria of values greater than or equal to $200,000. Excel returns a value of 9.
6. Select C25 and in the Function Library group, click Recently Used.
7. Select COUNTIF. In the Functions Arguments box, in the Range box, select cells C5:C16.
8. In the Criteria box, type >=200000 and press Tab. Preview the result and click OK. 
a. Excel returns a value of 7 when the formula is applied to the cell.



Using AVERAGE
Returns the average of all the cells in a range that meet a given criteria.
Action:
1. Select C27 and click the Insert Function Symbol.
2. Search for and select AVERAGE.
3. In the Number1 box, type B5:B16 and click OK. 
4. Select C28 and in the Function Library group, click Insert Function.
5. Select AVERAGEIF from the function list or use the function search box to locate and accept.
6. In the Function Arguments dialog box, in the Range box, select cells B5:B16.
7. In the Criteria box, type >=200000.
8. In the Average_range box, select F5:F16 and press Tab. In the preview, Excel returns a value of 63.33.
9. Click OK to close the dialog box.

LESSON ITEM #10:  Use Formulas to Look Up Data in a Workbook
Using VLOOKUP
Used when the comparison value is in the first column of the table. Excel goes down the first column until a match is found and then looks in one of the columns to the right to find the value in the same row. 
Action:
1. Go to the LOOKUP practice tab.
2. Select cells A15:C20 in the worksheet.
3. Click the Formulas tab, and in the Defined Names group, click Define Name. 
4. In the New Name dialog box, in the Name box, type Bonus. 
5. Click OK.
6. Click cell E5, select the Insert Function symbol, find and select VLOOKUP.
7. In the Lookup_value text box, type B5 and press Tab. 
8. In the Table_array box, go back to the Formulas tab and choose the Use in Formula drop down. Select Bonus.
a. This will use the array of information we defined.
9. In the Col_index_num box, type 2, which is the column containing the individual bonus amounts.
10. Press Tab.
11. In the Range_lookup box, type True, which means that VLOOKUP can check for the nearest value that does not go over the number in the first column; the same bonus is paid for a range of years, so you enter True in the Range_lookup box so that a value will be returned for all agents. 
12. Click OK. Excel returns a value of 2.5%.
13. Using the fill handle in cell E5, copy the formula to E6:E11. 
a. The reason E11 shows #N/A is because the agent has only been with the company for 0.5 years. This means, this agent will not receive a bonus.
14. Click in cell F5 and type =VLOOKUP(B5,Bonus,3).
15. Press Enter. 
16. Copy the formula from F5 to F6:F11.
17. 

Using HLOOKUP
Searches horizontally for a value in the top row of a table or an array and then returns a value in the same column from a row you specify in the table or array.
Action:
1. Click the HLOOKUP Practice tab.
2. Click cell F11.
3. Click the Insert Function Symbol, find and select HLOOKUP.
4. In the Lookup_value text box, type E11. 
a. This is the cell you will change and the box previews to Feet because that is what is currently typed in cell E11.
5. In the Table_array text box, type A1:D7. 
a. This will be the range of cells you will look in.
6. In the Row_index_num, type D11+1. 
7. This currently evaluates to 3. If you just do the number of beds that is in D11, you don’t come down enough rows because of the labels in the first row of the Table_array. The number of beds is actually one row more than the number of beds because the labels (Beds, CO2, Exits, and Feet) count as the first row and row 2 is for 1 bed.
8. In Range_lookup, type FALSE because you want an exact match. 
9. Click OK. 
10. In cell D11, type 5 and hit the Enter key. Notice that the result in F11 changes to 2500.
11. In cell E11, type CO2 and press the Enter key. Notice that the result changes to the result for the CO2 column for 5 beds, which is 3.
12. Click cell D11, and then type 7 and press the Enter key. Notice that you get a #REF! Error because the table only goes up to five beds.
13. In cell D11, type 1. Cell F11 displays a result of 1.

LESSON ITEM #11:  Using Formulas to Modify Text
Convert Text to Columns
Action:
1. Go to the Text-to-Columns tab.
2. Select cells A2:A8. 
3. Click the Data tab and in the Data Tools group, click Text to Columns.
4. A Convert Text to Columns Wizard opens. 
5. Delimited is the default because Excel recognizes that the data in the select range is separated with commas.
6. Click Next.
7. Select Comma as the delimiter and deselect tabs.
8. Click Next and then click Finish. 



Using LEFT
Evaluates a string and takes any number of characters on the left side of the string.
Action:
1. Click cell H1, type Ext, and in I1, type Floor to label the columns.
2. Select cell H2.
3. Click the Insert Formulas Symbol, find and select LEFT.
4. In the Text box, click A2 and press Tab.
5. In the Num_chars box, type 3 and press Tab. 
6. Click OK and double-click on the fill handle in the bottom right of cell H2 to copy the formula in H2 from H3 to H8.
7. Select cell I2, click the Recently Used button on the Formulas tab, and select LEFT.
8. In the Text box, type A2, press Tab, and in the Num_chars box, type 1. Click OK.
9. Copy the formula in I2 from I3 to I8.

Using RIGHT
Returns the number of characters on the right side of the text string. 
Action:
1. Click cell J1, and then type Birthday. 
2. In cell K1, type EmpID.
3. Select cell J2.
4. Click the Insert Formulas Symbol, find and select RIGHT. 
5. In the Text box, click E2 and press Tab.
6. In the Num_chars box, type 3 and press Tab. 
7. Click OK and copy the formula in J2 from J3 to J8.
8. Select cell K2, type =RIGHT(A2,5), and press Enter.
9. Copy the formula in K2 from K3 to K8.

Using MID
Returns characters in the middle. 
Action:
1. Click cell L1, and then type empcat1, and in cell M1, type empcat2.
2. Select cell L2.
3. Click the Insert Formulas Symbol, find and select MID.
4. The Function Arguments dialog box opens.
5. In the Text box, click A2 and press Tab.
6. The starting point of the empcat1 value is the fourth character of (425oonp15210), so type a 4 in the Start_num text box.
7. In the Num_chars box, type 2. The preview of the result shows oo.
8. Click OK and copy the formula in L2 from L3 to L8.
9. Select cell M2, and type =MID(A2,6,2), and press Enter.
10. Copy the formula in M2 from M3 to M8.
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CONGRATULATIONS – YOU’VE FINISHED!!!
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